WikiWirral is where great friendships are made.
Forum Stats
12223 Members
65 Forums
72737 Topics
980369 Posts
26 posts in the last 24hrs
Max Online: 7831 @ 8th Apr 2013 4:18pm
Who's Online - Click Me
94 registered (11kendo, 16 invisible), 1834 Guests and 180 Spiders online.
Key: Admin, Global Mod, Mod
Social Media : Follow Us


(Views 7days)This Weeks Most Read
On-street parking charges dropped 432
TS Indefatigable 402
Patio work 309
vet fees 264
Hezballah 237
Sea Shepherd 219
Seeking old pictures of Egerton Street area, Birkenhead 110
Re sizing 79
Am I missing something ? 66
TV wall mount wanted. 56
New General Forums
Ice in the 1800's
by granny
09:47 PM
Am I missing something ?
by dizdazdoz
16th Feb 2017 12:46pm
Valentines Day---Help From The Ladies
by fish5133
10th Feb 2017 7:35pm
Happy BirthdaY
by Vanmanone
10th Feb 2017 2:51am
New Wirral History
Seeking old pictures of Egerton Street area, Birkenhead
by yoller
19th Feb 2017 7:53pm
TS Indefatigable
by granny
18th Feb 2017 3:32pm
RIP : Chris Kay
by granny
31st Aug 2016 9:25am
Children's home on the Overchurch
by xleahx
26th Apr 2011 7:01pm
Stanlow Abbey
by ghostly1
4th Dec 2008 10:09pm
Forum Tips
Photo Gallery Forums
fireworks on the Mersey last night
Hadlow train station
Topic Replies
Internet Explorer Not Working
by diggingdeeper
02:39 AM
Changes to bin collections
by fish5133
11:14 PM
TV wall mount wanted.
by j_demo
09:32 PM
Samick Greg Bennett UK50 Ukulele
by kenmo52
07:44 PM
TS Indefatigable
by granny
06:11 PM
Patio work
by steamfan
09:51 AM
Missing
by granny
20th Feb 2017 11:10pm
Stanlow Abbey
by techgran
20th Feb 2017 9:07pm
2x Brit Floyd tickets 3rd March City entrance
by ambersmum
20th Feb 2017 6:35pm
February
M Tu W Th F Sa Su
1 2 3 4 5
6 7 8 9 10 11 12
13 14 15 16 17 18 19
20 21 22 23 24 25 26
27 28
Recent Posts : What's On ?
Lion Salt Works/Weaver Hall Museum
by venice
19th Feb 2017 12:19pm
Wirral TUC Meeting re Update on Wallasey CLP Suspe
by RUDEBOX
13th Feb 2017 8:50pm
Page 1 of 2 1 2 >
Topic Options
Rate This Topic
#274225 - 7th Dec 2008 9:20pm Running problems on RST again.
Dave100e Offline

Veteran

Registered: 14th Jul 2008
Posts: 690
Loc: Greasby
Its doing my head in now.

I mentioned it in the past but it went and now its doing it again. As i drive along it stutters and throws a load of fuel down the exhaust (i think) so you get a bang and sometimes flame. It seems to do it only under about half throttle and up and when the car comes on boost, but not always. You can hold 10psi or more and its ok then suddenly itll do it at 2psi. Its completely intermittent and i see no connection of circumstances between when its happened. Sometimes itll drive off, sometimes it wont.

Ive removed the filter, no change. Ive added injector cleaner, and it didnt do it again for a while but i dont reckon that helped. Leads and dizzy are ok. Some people suggested the cam but i dont want to fork out on it if it turns out not to be. After that it starts getting into electronics.

Any ideas anyone?

And can anyone suggest somewhere to go to get it looked at who know their stuff? Im getting fed up now.
_________________________
I HATE cars.

Top
AutoWirral : Advertising
Click me for more Information......

WikiWirral Numbers : Between 150 and 200 New Members Every Month. With Over 3,500 unique visits and 35,000 Page Views each day. Average +500 Search Engines Daily and over 1,000,000 Million Page views a Month. Advertising from £20 . Click Me
#274431 - 8th Dec 2008 9:04am Re: Running problems on RST again. [Re: Dave100e]
StuyMac Offline

Wiki Master

Registered: 24th Nov 2003
Posts: 12002
Loc: Wirralshire
Deffo an electrical problem.

Possibly the MAP sensor.... think
_________________________


What If There Were No Hypothetical Questions?

Top
#274693 - 8th Dec 2008 8:04pm Re: Running problems on RST again. [Re: StuyMac]
Dj_Macca Offline
Member

Registered: 26th Nov 2008
Posts: 51
Loc: Claughton Village
isnt it called MAF
_________________________

Top
#274699 - 8th Dec 2008 8:21pm Re: Running problems on RST again. [Re: Dj_Macca]
StuyMac Offline

Wiki Master

Registered: 24th Nov 2003
Posts: 12002
Loc: Wirralshire
MAF is a Mass Air Flow sensor and works with a hot wire to measure air flow in to the engine.

The Turbo'd fords use a MAP (Manifold Absolute Pressure) sensor to measure inlet manifold pressure as a way of measuring air going in to the engine smile

The both do the same job of measuring air going in to the engine, though technically the MAP sensor method is more accurate on a F/A car.
_________________________


What If There Were No Hypothetical Questions?

Top
#274907 - 9th Dec 2008 10:06pm Re: Running problems on RST again. [Re: StuyMac]
Dave100e Offline

Veteran

Registered: 14th Jul 2008
Posts: 690
Loc: Greasby
OK cheers. Would that still cause it to be intermittent though?

I went out today and it was fine but once it got some welly it started again.

Ill see about getting it changed either way, at least its one less thing it could be.
_________________________
I HATE cars.

Top
#274939 - 9th Dec 2008 11:08pm Re: Running problems on RST again. [Re: Dave100e]
StuyMac Offline

Wiki Master

Registered: 24th Nov 2003
Posts: 12002
Loc: Wirralshire
Its a pressure sensor - first time you give it some it may stick open and take a while to close again.... think
_________________________


What If There Were No Hypothetical Questions?

Top
#274954 - 10th Dec 2008 12:11am Re: Running problems on RST again. [Re: StuyMac]
Dave100e Offline

Veteran

Registered: 14th Jul 2008
Posts: 690
Loc: Greasby
OK, ill give it a try then.

Does the type of sensor reprisent the pressure it can read. For example, a 1.5 bar MAP will read up to 1.5 bar, and a 2, 2.5 and 3 bar all the same or is there a difference?

What happened to the good old days of twisting screws on carbs eh?
_________________________
I HATE cars.

Top
#274955 - 10th Dec 2008 12:27am Re: Running problems on RST again. [Re: Dave100e]
Dave100e Offline

Veteran

Registered: 14th Jul 2008
Posts: 690
Loc: Greasby
I cant any map or maf sensors, and i had a look at the car and the things i can find are a pipe to the ecu from the manifold and a sensor on the charge carrier. Ive found these on burton power and its described as 'AIR CHARGE SENSOR ESCORT RS TURBO -5/90'. Do you think that is the sensor im after?
_________________________
I HATE cars.

Top
#274956 - 10th Dec 2008 12:41am Re: Running problems on RST again. [Re: Dave100e]
StuyMac Offline

Wiki Master

Registered: 24th Nov 2003
Posts: 12002
Loc: Wirralshire
Ive only heard them called MAP sensor matey...

1 bar with MAP sensor is atmospheric, so a 2 bar sensor is accurate up to 15psi / 1 bar, and a 3 bar MAP sensor is good for 2 bar (30psi) boost pressure.

Its generally a small unit with a pressure / vacume feed and a loom connector.

There are quite a few 3 bar items, though Im not sure if these will run on your ECU think

_________________________


What If There Were No Hypothetical Questions?

Top
#274959 - 10th Dec 2008 1:04am Re: Running problems on RST again. [Re: StuyMac]
Dave100e Offline

Veteran

Registered: 14th Jul 2008
Posts: 690
Loc: Greasby
Well im running 17psi atm so id expect a 2.5 or 3bar jobbie then. I hope anyway. Ill have a proper look again in the light tommorow. Just had a look again and theres a black thing opposite where the cable pulls the throttle body. I always thought it was the throttle position sensor but it looks similar to the MAP sensors in pictures. As i said, ill have a proper look in the afternoon, im tired now.

Cheers for the help btw, much appreciated.
_________________________
I HATE cars.

Top
#275003 - 10th Dec 2008 2:27pm Re: Running problems on RST again. [Re: Dave100e]
StuyMac Offline

Wiki Master

Registered: 24th Nov 2003
Posts: 12002
Loc: Wirralshire
Chances are that is the TPS - the MAP sensors are generally mounted on the bulkhead, away from the heat and vibrations of the engine.

f you find you have a 2 bar map sensor (I belive this is std) and your running 17psi, that could well be the problem...
_________________________


What If There Were No Hypothetical Questions?

Top
#275027 - 10th Dec 2008 4:54pm Re: Running problems on RST again. [Re: StuyMac]
Dave100e Offline

Veteran

Registered: 14th Jul 2008
Posts: 690
Loc: Greasby
I had a better look today. That is the Throttle pot. Theres a funny pipe that runs round the back of the manifold but it then goes into a round filter type thing and back into the manifold at the back. Theres also a pipe from the top of the manifold that runs straight to the ecu. If i opened the ecu up do you think i might find the MAP sensor in there?
_________________________
I HATE cars.

Top
#275109 - 11th Dec 2008 12:11pm Re: Running problems on RST again. [Re: Dave100e]
DavidB Offline
Wiki Guide

Registered: 7th Dec 2003
Posts: 5595
Loc: Bebington, Wirral
Sounds like something simple like your plugs - are they gapped properly? You could also have fuel leaking into the inlet through dodgy, leaking injectors or your Fuel Pressure Regulator.
Does it come on after a certain period of time (like motorway driving)?
_________________________
"C20 LET bang"

Top
#275110 - 11th Dec 2008 12:40pm Re: Running problems on RST again. [Re: DavidB]
StuyMac Offline

Wiki Master

Registered: 24th Nov 2003
Posts: 12002
Loc: Wirralshire
Good point Station, though the S1 and S2 use a mechanical, Bosch, Fuel injector system - it could have something to do with that.... think

Its a bit of trial and error Dave, I think you really do need to change some parts for known working items to rule things out though...
_________________________


What If There Were No Hypothetical Questions?

Top
#275216 - 11th Dec 2008 7:40pm Re: Running problems on RST again. [Re: StuyMac]
Dave100e Offline

Veteran

Registered: 14th Jul 2008
Posts: 690
Loc: Greasby
I know the leads are good.
Ill try the plugs next. Ill whip em out n clean them if i get a chance on the weekend. Check the gaps too. I know they need to be pretty small on a high boost car.
It has a brand new higher pressure electronic pump so i know thats good but im not too sure about the rest of the fuel system. I guess ill have to get the injectors spray tested and leak tested.
I dont really want to get too involved about the fuel injection system, i dont really know much about it to be honest. I know how it all works, just no experience with it.
_________________________
I HATE cars.

Top
Page 1 of 2 1 2 >

Moderator:  StuyMac 
Random Wirral Images

Click to View Topic.
Newest Topics
Internet Explorer Not Working
by fish5133
12:25 AM
vet fees
by eggandchips
20th Feb 2017 12:01am
Seeking old pictures of Egerton Street area, Birkenhead
by yoller
19th Feb 2017 7:53pm
Lion Salt Works/Weaver Hall Museum
by paxvobiscum
18th Feb 2017 9:19pm
Patio work
by steamfan
18th Feb 2017 3:45pm
For Sale & Free
TV wall mount wanted.
by j_demo
07:53 PM
Samick Greg Bennett UK50 Ukulele
by j_demo
20th Feb 2017 9:24pm
2x Brit Floyd tickets 3rd March City entrance
by ambersmum
20th Feb 2017 6:35pm
Sherwood 2x30W amp with phono - £35; other hifi
by montyz
20th Feb 2017 4:09pm
Gaming pc
by Cjoshea
18th Feb 2017 9:47pm
Featured Member
Registered: 16th Aug 2013
Posts: 1583
Newest Members
CliveK, vonny, Vkj530, SunsetP, RachelBinns
12223 Registered Users
Today's Birthdays
j_demo (28)
New Wirral Info
Lion Salt Works/Weaver Hall Museum
by paxvobiscum
18th Feb 2017 9:19pm
Patio work
by steamfan
18th Feb 2017 3:45pm
Ceiling needs smoothing
by yr20405
15th Feb 2017 1:52am
Info? Bill Dobson, Photographer, Martins Bank
by diggingdeeper
13th Feb 2017 12:10pm
War Museum
by missmahjong
12th Feb 2017 1:24pm
News : New Topics
Hezballah
by venice
17th Feb 2017 11:15am
On-street parking charges dropped
by oldpm01
15th Feb 2017 9:10am
Thousands raised for children of cancer couple.
by fish5133
13th Feb 2017 3:01pm
Lost ladies Swarovski watch
by spider
13th Feb 2017 10:36am
M53 closed in both directions between J2 and J3
by diggingdeeper
9th Feb 2017 10:00pm
New Enthusiast Forums
Internet Explorer Not Working
by fish5133
12:25 AM
vet fees
by eggandchips
20th Feb 2017 12:01am
Sea Shepherd
by venice
16th Feb 2017 1:06pm
Sounds of the Sixties
by paxvobiscum
11th Feb 2017 8:53pm
Hospital
by cools
10th Feb 2017 9:53am
(Views 24hrs)Trending Newest Topics
TV wall mount wanted. 56
Internet Explorer Not Working 23
Ice in the 1800's 11
Wirral Sunrise Sunset
Sunrise Wed 7:13am
Sunset Wed 5:37pm
Local Time Wed 4:52am
WikiWirral Can . . . .